Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Python Extension don't load in Burp on Fedora

jcubic Dec 21, 2017 08:33AM UTC

I've create test python extension:
<pre>
from burp import IBurpExtender

class BurpExtender(IBurpExtender):

def registerExtenderCallbacks(self, callbacks):
# your extension code here
return
</pre>

<pre>
java.lang.NoClassDefFoundError: com/google/common/collect/MapMaker
</pre>

I've installed jython using Fedora installer and put path to jython.jar in options but I didn't use path to load modules.

Is python require something else (google modules) to be installed?


Paul Johnston Dec 21, 2017 10:23AM UTC Support Center agent

You need to use the Jython standalone jar which includes all the dependencies in a single jar. The error shows you’ve used the Jython jar that does not include dependencies.


jcubic Dec 22, 2017 09:36AM UTC
I've found this old bug report https://bugzilla.redhat.com/show_bug.cgi?id=1178546

I've try to run burp using provided fix:

java -cp $(build-classpath jython/jython guava jnr-constants jnr-ffi jnr-netdb jnr-posix jffi libreadline-java/libreadline-java jline1/jline-1 antlr32/antlr-runtime objectweb-asm/asm objectweb-asm/asm-commons objectweb-asm/asm-util commons-compress icu4j netty/netty-buffer netty/netty-codec netty/netty-common netty/netty-handler netty/netty-transport):. -Dpython.home=/usr/share/jython -jar burpsuite_community_v1.7.30.jar

but it didn't help and I can't put class path because options accept single folder.

Paul Johnston Dec 22, 2017 09:40AM UTC Support Center agent

Did you try using the Jython standalone jar? It should be approximately 37mb in size. If yours is much smaller, you are using the wrong jar.

If you’re still having difficulty, please reply with a screenshot of the Extender > Options screen.


jcubic Dec 22, 2017 09:46AM UTC
Thanks it work

Post Your public answer

Your name
Your email address
Answer