Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Failed to load any python extension

Thomas Sep 06, 2018 03:40PM UTC

I have a problem with loading any python base extension in burp. I downloaded a jyton-standalone-2.7.0.jar and also configured python environment in extender options but when I want to install any python base extension via BApp Store I get error in the bottom right corrner "Failde to load BApp".
I am using java in version - jdk-9.0.4 (burp is working fine).

Does anyone know where the error may be?

Liam Tai-Hogan Sep 07, 2018 07:08AM UTC Support Center agent

Are you able to load other python based extensions?

Thomas Sep 07, 2018 07:32AM UTC
I tried serveral different extensions (Active Scan ++, Add & Track Custom Issues, Identity Crisis) but with not success. I am using burp in version 1.7.37.

Liam Tai-Hogan Sep 07, 2018 08:05AM UTC Support Center agent

Have you tried following our support page for installing an extension?


Thomas Sep 07, 2018 08:42AM UTC
Yes, off course I tried it. What is more, when I check Errors tab in Burp Extensions I get the following Traceback:

Traceback (most recent call last):
File "C:\work\programs\Jython\jython-standalone-2.7.0.jar\Lib\", line 585, in <module>
File "C:\work\programs\Jython\jython-standalone-2.7.0.jar\Lib\", line 567, in main
File "C:\work\programs\Jython\jython-standalone-2.7.0.jar\Lib\", line 300, in addusersitepackages
File "C:\work\programs\Jython\jython-standalone-2.7.0.jar\Lib\", line 289, in getusersitepackages
File "C:\work\programs\Jython\jython-standalone-2.7.0.jar\Lib\", line 416, in get_path
File "C:\work\programs\Jython\jython-standalone-2.7.0.jar\Lib\", line 407, in get_paths
File "C:\work\programs\Jython\jython-standalone-2.7.0.jar\Lib\", line 180, in _expand_vars
File "C:\work\programs\Jython\jython-standalone-2.7.0.jar\Lib\", line 154, in _subst_vars
File "C:\work\programs\Jython\jython-standalone-2.7.0.jar\Lib\", line 154, in _subst_vars
UnicodeEncodeError: 'ascii' codec can't encode character u'\u0142' in position 13: ordinal not in range(128)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
at java.lang.reflect.Constructor.newInstance(
at burp.mke.<init>(Unknown Source)
at burp.igf.a(Unknown Source)
at burp.d1e.a(Unknown Source)
at burp.d1e.a(Unknown Source)
at Source)

Paul Johnston Sep 07, 2018 10:11AM UTC Support Center agent

Hi Thomas,

Thanks for providing the stack trace. It shows Jython throwing a Unicode exception when it’s trying to load your user site packages. I wonder, does your user name include a non-ASCII character? You may have discovered a Jython bug here. Let us know as if that is the problem we may be able to identify a workaround, such as setting the USER_SITE environment variable to a path that only contains ASCII characters.

Please let us know if you need any further assistance.

Thomas Sep 07, 2018 10:48AM UTC
Yes you are rigth, my user name include non-ASCII character

Paul Johnston Sep 07, 2018 01:29PM UTC Support Center agent

Hi Thomas,

Ok, I’ve just checked to see if I can find a workaround for this issue, but have not been successful. I think the only way you’ll get Jython extensions to work is to rename your user account to contain only ASCII characters.

It might be worth reporting to Jython. Some quick searching revealed some similar issues, although the project has not done a release for some time.

Please let us know if you need any further assistance.

Thomas Sep 07, 2018 02:20PM UTC
Thanks for your help, I don't need your further assistance

Post Your public answer

Your name
Your email address