Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Embedded browser initialization failed

Dan Williams May 28, 2019 03:58PM UTC

Hi

I am having an issue with the Response/Render feature of the embedded browser.

When I click on "Render" in the "Response" tab I receive the following message "Embedded browser initialization failed"

I also ran the Embedded browser health check and I get the following messages.

Checking Platform Support - Success
Checking Browser Binaries - Success
Creating embbeded browser documenation window - Error

Aborting checks due to errors.
java.io.EOFException

Burp Pro v2.0.22beta
Kali Linux with all updates as of 2019-05-28

I have also attempted to update the installation and this did not resolve the issue.

Any ideas?

Thanks

Dan


Liam Tai-Hogan May 30, 2019 09:55AM UTC Support Center agent

Thanks for the info, Dan.

We’re hoping to release a workaround for this issue in the next update of Burp 2.×.


Rose Krawczuk Jun 13, 2019 09:08AM UTC Support Center agent

We expect this issue to have been fixed in the latest release: v2.0.24beta.

Let us know if you’re still experiencing issues.


Shubham Jun 18, 2019 09:37AM UTC
Issue still exists.

OS: Kali Linux with latest updates
Burp Suite: Pro v2.0.24beta

"Creating embedded browser documentation window Error"

"Aborting checks due to errors.

java.io.EOFException"

Paul Johnston Jun 19, 2019 03:09PM UTC Support Center agent

Shubham – sorry to hear you’re still having difficulty. Can you please email support@portswigger.net with your Diagnostics and Embedded browser health check – which are both on the Help menu.


Pepita Jul 01, 2019 01:42PM UTC
Hello,

I've just updated to v2.1 and I'm having the same error as above. Could you advise?

Thanks,

Rose Krawczuk Jul 02, 2019 01:13PM UTC Support Center agent

Pepita– sorry to hear you’re still having difficulty. Can you please email support@portswigger.net with your Diagnostics and Embedded browser health check – which are both on the Help menu.


Louis Jul 26, 2019 02:16PM UTC
I had the same problem (Debian Stretch all upadtes, Burp Pro 2.1.02), but I found a java debug log which said:

[0726/153651.016897:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper b
inary was found, but is not configured correctly. Rather than run without sandbo
xing I'm aborting now. You need to make sure that /home/.../.BurpSuite/burpbrowser/0.122/lib/chrome-sandbox is owned by root and has mode 4755.

I did the change and everything is working.

Regards

Rose Krawczuk Jul 29, 2019 10:11AM UTC Support Center agent

Thanks, Louis. When running as root, the embedded browser sandbox is switched off. Another workaround for this is to Disable the embedded browser sandbox when running as a non-root user (User options > Display > HTML Rendering > Enable embedded browser sandbox).

Our development team are looking into a fix for this.


Simon Waters Sep 13, 2019 08:05PM UTC
Still seeing this in 2.1.03 on Debian Buster.

If I disable the browser sandbox (eek) the health check then fails at:

"Unable to created headless browser."

See same debug message as Louis above, although needing to grant root privilege in order to run a browser feels very wrong, now if you'd said send corrupt IP packets I'd have understood.

Changing the ownership and permissions to those in the debug log and enabling the sandbox works. All tests pass. I can read the Help pages again.


Florian Pfitzer Sep 16, 2019 05:58AM UTC
Running

sudo sysctl -w kernel.unprivileged_userns_clone=1

fixed it for me.

Post Your public answer

Your name
Your email address
Answer