Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

2.1 Load from Configuration File help

Adam Coombs Jul 16, 2019 04:32PM UTC

I trying to get user setting to work like I had in the older version 1.7.37
Does not work at all.
I try to create a new one that did not save any settings, example Proxy tab having the Intercept is off not on.
I try to create a project with the setting, then open that project that does not work either.

please help


Liam Tai-Hogan Jul 17, 2019 12:49PM UTC Support Center agent

Proxy Interception settings are saved as part of a user config file:

- https://portswigger.net/burp/documentation/desktop/getting-started/configuration

Are you saving and using the correct file type?


Adam Coombs Jul 17, 2019 08:46PM UTC
Liam,
Yes, I am saving them as .json file.
Also, I have try to save with a .json ext. Burp Suite automatically adds .json ext if you do not added it.

I can post on here if that would help.

Liam Tai-Hogan Jul 18, 2019 03:02PM UTC Support Center agent

Adam, if you’re happy to post on here that would certainly help us understand the issue you are encountering.


Adam Coombs Jul 18, 2019 03:13PM UTC
I can not post it, errors out.
I have try to replace {} with # does not matter.

{
"user_options":{
"connections":{
"platform_authentication":{
"credentials":[],
"do_platform_authentication":true,
"prompt_on_authentication_failure":false
},
"socks_proxy":{
"dns_over_socks":false,
"host":"",
"password":"",
"port":0,
"use_proxy":false,
"username":""
},
"upstream_proxy":{
"servers":[]
}
},
"display":{
"character_sets":{
"mode":"recognize_automatically"
},
"html_rendering":{
"allow_http_requests":true,
"enable_embedded_browser_sandbox":true
},
"http_message_display":{
"font_name":"Courier",
"font_size":11,
"font_smoothing":true,
"highlight_requests":true,
"highlight_responses":true
},
"user_interface":{
"font_size":11,
"look_and_feel":"Nimbus"
}
},
"extender":{
"extensions":[],
"java":{
"folder_for_loading_library_jar_files":""
},
"python":{
"folder_for_loading_modules":"",
"location_of_jython_standalone_jar_file":"/home/securitytool/standalonejython/remotecontent/jython.jar"
},
"ruby":{
"location_of_jruby_jar_file":""
},
"settings":{
"automatically_reload_extensions_on_startup":true,
"automatically_update_bapps_on_startup":true
}
},
"misc":{
"api":{
"address":"",
"enabled":false,
"insecure_mode":false,
"keys":[],
"listen_mode":"loopback_only",
"port":1337
},
"automatic_project_backup":{
"delete_on_shutdown":true,
"enabled":true,
"in_scope_only":false,
"interval":30,
"show_progress":true
},
"enable_proxy_interception_at_startup":"always",
"hotkeys":[
{
"action":"send_to_repeater",
"hotkey":"Ctrl+R"
},
{
"action":"send_to_intruder",
"hotkey":"Ctrl+I"
},
{
"action":"forward_intercepted_proxy_message",
"hotkey":"Ctrl+F"
},
{
"action":"toggle_proxy_interception",
"hotkey":"Ctrl+T"
},
{
"action":"switch_to_target",
"hotkey":"Ctrl+Shift+T"
},
{
"action":"switch_to_proxy",
"hotkey":"Ctrl+Shift+P"
},
{
"action":"switch_to_intruder",
"hotkey":"Ctrl+Shift+I"
},
{
"action":"switch_to_repeater",
"hotkey":"Ctrl+Shift+R"
},
{
"action":"switch_to_project_options",
"hotkey":"Ctrl+Shift+O"
},
{
"action":"switch_to_alerts_tab",
"hotkey":"Ctrl+Shift+A"
},
{
"action":"go_to_previous_tab",
"hotkey":"Ctrl+Minus"
},
{
"action":"go_to_next_tab",
"hotkey":"Ctrl+Equals"
},
{
"action":"editor_cut",
"hotkey":"Ctrl+X"
},
{
"action":"editor_copy",
"hotkey":"Ctrl+C"
},
{
"action":"editor_paste",
"hotkey":"Ctrl+V"
},
{
"action":"editor_undo",
"hotkey":"Ctrl+Z"
},
{
"action":"editor_redo",
"hotkey":"Ctrl+Y"
},
{
"action":"editor_select_all",
"hotkey":"Ctrl+A"
},
{
"action":"editor_search",
"hotkey":"Ctrl+S"
},
{
"action":"editor_go_to_previous_search_match",
"hotkey":"Ctrl+Comma"
},
{
"action":"editor_go_to_next_search_match",
"hotkey":"Ctrl+Period"
},
{
"action":"editor_url_decode",
"hotkey":"Ctrl+Shift+U"
},
{
"action":"editor_url_encode_key_characters",
"hotkey":"Ctrl+U"
},
{
"action":"editor_html_decode",
"hotkey":"Ctrl+Shift+H"
},
{
"action":"editor_html_encode_key_characters",
"hotkey":"Ctrl+H"
},
{
"action":"editor_base64_decode",
"hotkey":"Ctrl+Shift+B"
},
{
"action":"editor_base64_encode",
"hotkey":"Ctrl+B"
},
{
"action":"editor_backspace_word",
"hotkey":"Ctrl+Backspace"
},
{
"action":"editor_delete_word",
"hotkey":"Ctrl+Delete"
},
{
"action":"editor_delete_line",
"hotkey":"Ctrl+D"
},
{
"action":"editor_go_to_previous_word",
"hotkey":"Ctrl+Left"
},
{
"action":"editor_go_to_previous_word_extend_selection",
"hotkey":"Ctrl+Shift+Left"
},
{
"action":"editor_go_to_next_word",
"hotkey":"Ctrl+Right"
},
{
"action":"editor_go_to_next_word_extend_selection",
"hotkey":"Ctrl+Shift+Right"
},
{
"action":"editor_go_to_previous_paragraph",
"hotkey":"Ctrl+Up"
},
{
"action":"editor_go_to_previous_paragraph_extend_selection",
"hotkey":"Ctrl+Shift+Up"
},
{
"action":"editor_go_to_next_paragraph",
"hotkey":"Ctrl+Down"
},
{
"action":"editor_go_to_next_paragraph_extend_selection",
"hotkey":"Ctrl+Shift+Down"
},
{
"action":"editor_go_to_start_of_document",
"hotkey":"Ctrl+Home"
},
{
"action":"editor_go_to_start_of_document_extend_selection",
"hotkey":"Ctrl+Shift+Home"
},
{
"action":"editor_go_to_end_of_document",
"hotkey":"Ctrl+End"
},
{
"action":"editor_go_to_end_of_document_extend_selection",
"hotkey":"Ctrl+Shift+End"
}
],
"out_of_scope_history_logging_action":"prompt",
"submit_anonymous_feedback":true,
"temporary_files_location":""
},
"proxy":{
"http_history":{
"sort_column":"#",
"sort_order":"ascending"
},
"websockets_history":{
"sort_column":"#",
"sort_order":"ascending"
}
},
"repeater":{
"view":"left_right_split"
},
"ssl":{
"client_certificates":{
"certificates":[]
},
"negotiation":{
"disable_sni_extension":false,
"enable_blocked_algorithms":true
}
},
"target":{
"view":"left_right_split"
}
}
}

Adam Coombs Jul 18, 2019 03:14PM UTC
added to the comment above,
I was able to posted the old user setting
Here is the I was trying to get work on the new burp

Liam Tai-Hogan Jul 22, 2019 09:40AM UTC Support Center agent

Thanks for the additional information Adam. We’ll check this out and let you know if we are able to reproduce your issue.


Adam Coombs Jul 22, 2019 04:00PM UTC
Awesome Liam

Thank you

Rose Krawczuk Jul 23, 2019 03:11PM UTC Support Center agent

Adam, just to confirm, user options are stored within the local installation of Burp, and are automatically reloaded each time Burp starts. They can also be saved and loaded from configuration files. So, if you are restarting Burp with particular user options on the same machine, then you should not need to load a user options file.

In the startup wizard, when creating or reopening a project, you can specify a configuration file from which to load project options, but not user options. This hasn’t actually changed between Burp 1.x and Burp 2.x, but I can see that there is a story in development to provide a warning when you try to load user options this way. I think it should be available in the next release.

You can still load user-level options when Burp is running: Burp > User options > Load user options.

If you’re wondering how to start Burp with the proxy intercept set to “off”, you’ll need to configure this in User options > Misc > Proxy Interception. I can see from the user options you have provided that you have this set to “Always enable”. You’ll need to change this to “Always disable” or “Restore setting from when Burp was last closed”, depending on what you want the behaviour to be.

If that does not answer your question, could you tell me the following:

- At what point are you trying to load the user settings? Can you send a screenshot?
- What exactly is the problem you’re encountering? Are you missing some of the settings or do you encounter an error message?


Adam Coombs Jul 23, 2019 07:25PM UTC
Hey Rose,
I am trying to get the load configuration file at start-up.
Here are my steps,
I open burp suite from my application list
Temporary project is selected. No project is selected
I select next, I use Burp defaults, then Select Start Burp.
Then Burp Suite startes
Then, I go to Proxy Tab, then Intercept, next select Intercept is on icon change it to Intercept is off.
Then I go to HTTP history tab and move the IP column to right next to Host Column.
Then go back to Dashboard,
The select Burp, then User options, select Save user options.
New window comes, up and I select local folder to save this. Filename with .json ext.

Close the burp answer question yes to close.
Open Burp Suite again, Temporary project is selected, then select next.
Then, I select Load from configuration file, then select Choose file. New windows opens, I go to the location where I save the user options file.. Press okay, the file location is file out next to Choose File icon. Then I select Start Burp.

Next step, I go to Proxy table to see if Intercept is set to off and HTTP history Ip address column is correct. All setting are default.

I can not post screenshots on public posted

Adam Coombs Jul 23, 2019 08:35PM UTC
To get the Intercept not enable when loading the program through Load from configuration file option.

I had to go to proxy tab them options.
Go to Intercept Client Requests, deselect Intercept requests based on the following rules.
Select the gear and select save options , then save the file. It automatically save the file as a .json file.
close burp suite program, then when it came to use load from configuration file. I select the new file I create from Intercept Client Requests area.
Note: Intercept is still showing on, when you look at it on the Intercept tab.

Liam Tai-Hogan Jul 25, 2019 02:01PM UTC Support Center agent

Have you tried loading user config options via the command line?

—user-config-file – Load the specified user configuration file(s); this option may be repeated to load multiple files.

- https://support.portswigger.net/customer/portal/articles/2928360-using-burp-s-command-line-arguments


Adam Coombs Jul 25, 2019 02:25PM UTC
I have not tried that, reason have to have the jar not the execute file to those options loaded.
It was on my next step to try, was not sure how to get that to work exactly

Here was my first idea on this
java -jar burpsuite.jar --config-file test.json

I have been able to create many different json files from different parts of the program, just need to figure out how to load them all. New Burp Suite is so much, thank you

I do not know if this will work yet :)

Liam Tai-Hogan Jul 30, 2019 02:15PM UTC Support Center agent

Just to keep you updated. We released a feature in the latest version of Burp to warn users if the wrong type of configuration file is provided.


Adam Coombs Jul 31, 2019 04:33PM UTC
Cool, I just this post was update today.
I will try the new version and let you know.

Post Your public answer

Your name
Your email address
Answer