Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Broken link in extender

Erik Aug 16, 2019 01:21AM UTC

the "install Jython" link in Extender is 404 across all Jthyon extensions.

Liam Tai-Hogan Aug 16, 2019 01:42PM UTC Support Center agent

Thanks for pointing this out. We’ll get it fixed.

Ujjwal Sinha Aug 21, 2019 10:17AM UTC
Do we have any timeline for the fixes? This seems to affect all the extensions which have Jython JAR file dependency.

An error occurred while loading the extensions.

java.lang.Exception: Failed to open Jython JAR file
at burp.dho.<init>(Unknown Source)
at burp.hs.a(Unknown Source)
at burp.ge3.lambda$panelLoaded$0(Unknown Source)
at java.base/java.util.concurrent.Executors$
at java.base/
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.base/java.util.concurrent.ThreadPoolExecutor$
at java.base/

Liam Tai-Hogan Aug 21, 2019 10:53AM UTC Support Center agent

Ujjwal, we have this in our short term roadmap. Unfortunately, we can’t provide an exact ETA.

Ujjwal Sinha Sep 06, 2019 12:24PM UTC
As I said above, this issue prevents anyone to use Burp Extensions which have Jython JAR file dependency. Till the time fix is deployed, is there any way around to be able to use these extensions?

If there's no way around, please provide a timeline for the fix and release. I would appreciate your understanding in this regards.

Rose Krawczuk Sep 09, 2019 07:06AM UTC Support Center agent

Ujjwal, could you send us a screenshot your settings in Extender > Options > Python Environment to

Have you ensured you are using the standalone JAR:

If so, could you try and re-downloading and re-configuring this in Burp, please?

The original issue in this thread seems to just refer to a broken link in Burp as opposed to an issue running Extensions using Jython.

Jerry Sep 10, 2019 11:12AM UTC
The link in Burp should be updated to the following:

There is an "s" on download in the Burp link that needs to be removed. Current link looks as follows:

That's why the 404 error is coming up there

Liam Tai-Hogan Sep 27, 2019 12:35PM UTC Support Center agent

This issue is fixed in the latest version of Burp Suite (v2.1.04).

Post Your public answer

Your name
Your email address