Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

ReadHandShakeRecord Error in Burp Suite Community v2.1.02

Rishi T Sep 16, 2019 11:15AM UTC

Hi... I am getting 'ReadHandShakeRecord' error in Burp Suite Community edition v2.1.02. I have java Version 8 Update 221 installed on my Windows Server 2012 machine. I also set Proxy correctly in Burp Suite and in Browser too and also installed CA certificate. Can you please help me in resolving the issue?


Mike Eaton Sep 16, 2019 01:00PM UTC Support Center agent

Hi Rishi, can you give us some more context about your issue?

- What operation were you trying to perform when you received this error?
- What environment are you using Burp Suite in? E.g. company network.


Rishi T Sep 16, 2019 01:50PM UTC
Hi Mike, Here are more details required:

- I am just trying to browse DVWA application installed on localhost using Chrome browser and keeping proxy settings ON. When i hit the DVWA application URL, i get error ('1568637896065 Error Proxy The client failed to negotiate an SSL connection to www.google.com:443: Received fatal alert: certificate_unknown') first and then i get 'ReadHandShakeRecord' error.
Though i installed CA certificate correctly for Chrome Browser.

- About environment, I am using company network which does not have any firewall or network restrictions.
Burp Suite Community Edition v2.1.02
Chrome Browser
OS: Windows Server 2012 R2
Java Version : "1.8.0_221"

Please let me know any more information required. Thanks!

Mike Eaton Sep 17, 2019 07:31AM UTC Support Center agent

Hi Rishi,

Can you confirm that you have read and followed our guides on configuring your browser to work with Burp Suite and setting up your CA certificates?
- https://support.portswigger.net/customer/portal/articles/1783055-configuring-your-browser-to-work-with-burp
- https://support.portswigger.net/customer/portal/articles/1783075-installing-burp-s-ca-certificate-in-your-browser


Vertik Nov 21, 2019 12:03PM UTC
Hi,

I've the same issue and I've already check my browser configuration and certificate
I'm getting ReadHandShakeRecord error... any help?

Thanks!

Ben Wright Nov 21, 2019 02:08PM UTC Support Center agent

Hi Vertik,

Can you provide us with more details of the environment that you are using (Burp version, operating system etc) and what you were doing when you encountered this error?


Joel Cobbs Dec 21, 2019 08:07PM UTC
I also wanted to follow up on this as I'm receiving the same issue.

I have installed the cert following the directions. I am using Chrome version 79.0.3945.88 (64-bit) for the browser on Windows 10 Home version 1803. I am able to connect to the internet and my VPN, but when I switch the browser to the proxy for Burp (127.0.0.1:8080), which is done through the Control Panel, all connections fail. I have not found anything only with this same issue that has been resolved.

I have no tried any other task besides trying to navigate to google.com, PortSwigger.net, or any other website, where I receive an error saying:

Your connection is not private

NET:ERR_CERT_AUTHORITY_INVALID

Joel Cobbs Dec 21, 2019 08:11PM UTC
1 other follow-up, I have verified that the cert is in my Trusted Root Certification folder.

Michelle Gillian Dec 24, 2019 03:13PM UTC Support Center agent

The error ‘NET:ERR_CERT_AUTHORITY_INVALID’ usually relates to an issue with the installation of the CA certificate, so maybe it hasn’t quite installed properly even if it looks like it’s there.
Do you see the same if you import the Burp CA certificate into another browser (e.g. Firefox)?
Alternatively, it might be worth re-installing the Burp CA certificate

We have an article on our website which runs through the steps for various browsers if you need to double-check anything:
https://support.portswigger.net/customer/portal/articles/1783075-Installing_Installing%20CA%20Certificate.html


Post Your public answer

Your name
Your email address
Answer