Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Could not start Burp: java.lang.NullPointerException

Alessandro Solano Nov 27, 2019 02:33PM UTC

Hi everybody,

Today, after updating to latest version 2.1.06, I'm no longer able to launch Burp Pro.
I also tried uninstalling, reinstalling, downgrading, but I always get the same not-so-informative exception message: "Could not start Burp: java.lang.NullPointerException" right after the splash screen. Launching the burp jar directly produces the same exception.
I suspect it might have something to do with a somewhere hidden license file?

Sabando


Liam Tai-Hogan Nov 27, 2019 02:57PM UTC Support Center agent

Which OS are you using?

Which version of Java are you running?

What do you mean by hidden license file?


Alessandro Solano Nov 27, 2019 04:35PM UTC
I'm using the latest kali linux version, using the jre bundled with Burp. By hidden license file I mean some kind of information related to the license which is stored outside of the Burp installation directory, which I infer (might be wrong) from the fact that when moving the directory between machines the launcher asks for the license again.

Liam Tai-Hogan Nov 28, 2019 09:46AM UTC Support Center agent

We’ve checked the license associated with your company email and there don’t appear to be any issues.

Are you launching Burp Suite from the installation shortcut or from the command line?


Alessandro Solano Nov 28, 2019 01:48PM UTC
I've tried both, always getting the NullPointerException. I then moved my BurpSuitePro installation folder to another kali machine, reactivated the license and got back to work, but now this second instance seems to have lost some history information (like recently opened sessions) and a few installed plugins, even though I copied the whole folder to the machine and explicitely loaded my UserOptions from the old json file. Right now I'm able to work with the new machine, but I would need to get Burp to work on the old machine again.
Thank you for any further help troubleshooting this

Alessandro Solano Nov 28, 2019 02:00PM UTC
I also noticed that, on the old machine, when I upgraded Burp to the latest release the installer created a new installation shortcut in ~/.local/share/applications instead of rewriting the existing shortcut. Now I have two shortcuts that point to the same Burp shell script but with slightly different contents. Both call the same script which launches the same jar which gives the same NPE.

Existing one:
'Burp Suite Professional-0.desktop'

content:

#!/usr/bin/env xdg-open
[Desktop Entry]
Type=Application
Name=Burp Suite Professional
Exec="/home/sabando/BurpSuitePro/BurpSuitePro"
Icon=/home/sabando/BurpSuitePro/.install4j/BurpSuitePro.png
Categories=Application;


Newly created one:
install4j_84df1n-BurpSuitePro.desktop

content:

#!/usr/bin/env xdg-open
[Desktop Entry]
Type=Application
Name=Burp Suite Professional
Exec="/home/sabando/BurpSuitePro/BurpSuitePro" %U
Icon=/home/sabando/BurpSuitePro/.install4j/BurpSuitePro.png
Categories=Application;
StartupWMClass=install4j-burp-StartBurp

Ben Wright Nov 28, 2019 02:22PM UTC Support Center agent

Hi Alessandro,

Which version of Burp were you upgrading from? From your response, I assume that you have tried to upgrade directly from Burp (by using the Help → Check for updates menu option) and by downloading the installer from our website?

Also, what happens when you try and launch the Burp Community version that is preinstalled on your Kali machine? Does this have the same error or does it load successfully?


Alessandro Solano Nov 28, 2019 03:16PM UTC
Hi Ben,

I was upgrading from 2.1.04 to 2.1.06, having downloaded and launched the linux installer shell script from the "new version available" wizard that pops up at launch. I then also tried downloading the script directly from the website and checking its sha256 digest, still no luck.
I also tried launching Burp Pro both in the system JVM and the bundled JVM.

The preinstalled Burp Community version loads succesfully, it just shows an alert that warns about not being fully tested against the system JRE version of Debian.

Hannah Law Nov 28, 2019 04:18PM UTC Support Center agent

Hi Alessandro

Just to ensure we’re all testing with the same setup, can you download the latest 2.1.06 standalone JAR file from our website and attempt to start Burp Suite using Java. Would you then be able to provide a screenshot of your terminal so that we can see any error messages that may be occurring?

If you could also let us know which version of java you are currently using by running “java -version” in your command line, that would be helpful.


Alessandro Solano Dec 02, 2019 12:34PM UTC
Hi Hannah,

Sorry for the late reply, I was out of office.

There you go:

sabando@n0tab00k:~$ java -version
openjdk version "11.0.5" 2019-10-15
OpenJDK Runtime Environment (build 11.0.5+10-post-Debian-2)
OpenJDK 64-Bit Server VM (build 11.0.5+10-post-Debian-2, mixed mode, sharing)
sabando@n0tab00k:~$ java -jar burpsuite_pro_v2.1.06.jar
Your JRE appears to be version 11.0.5 from Debian
Burp has not been fully tested on this platform and you may experience problems.
Could not start Burp: java.lang.NullPointerException
sabando@n0tab00k:~$ ./BurpSuitePro/jre/bin/java -version
openjdk version "12.0.2" 2019-07-16
OpenJDK Runtime Environment (build 12.0.2+10)
OpenJDK 64-Bit Server VM (build 12.0.2+10, mixed mode)
sabando@n0tab00k:~$ ./BurpSuitePro/jre/bin/java -jar burpsuite_pro_v2.1.06.jar
Could not start Burp: java.lang.NullPointerException

Hannah Law Dec 04, 2019 12:06PM UTC Support Center agent

Hi Alessandro

Unfortunately, we have been unable to replicate this issue ourselves on a virtual machine.

As a further test, could you download a fresh copy of 2.1.06 and install it in a completely different location on your machine?


Alessandro Solano Dec 04, 2019 01:52PM UTC
Hi Hannah,

I already tried with a fresh copy of 2.1.06 installed in a different location and I got the same exception.
Would you be able to confirm whether Burp tries to read files from a global path which resides outside its install location (aside from /tmp)?

Thank you

Hannah Law Dec 04, 2019 03:37PM UTC Support Center agent

Burp reads config files from inside the .burpsuite folder in the user’s home directory.

It also has information contained within the java preferences store (~/.java/.userPrefs/burp) relating to licensing and extensions.

If you can send us your config files and burp preferences file (or use a screenshot) to support@portswigger.net, then we can have a look through to see if there are any misconfigurations.


Alessandro Solano Dec 04, 2019 04:16PM UTC
Thank you for the info, I was able to check the permissions on the .BurpSuitePro folder and found out it was owned by root. I gave ownership to my user and was able to launch Burp normally. I honestly don't know when and how the ownership was given to root since I always run Burp as a standard user.

So, the NullPointerException was apparently being thrown by an error when reading the content of the folder in a line of code that was added or changed between 2.1.04 and 2.1.06.
You might want to fix the code by adding a catch clause and handling the exception gracefully with a message to the user in a popup or something like that.

Cheers,
Alessandro

Hannah Law Dec 04, 2019 04:22PM UTC Support Center agent

Glad you managed to get it working. We’ll create a bug request to sort that NullPointerException out.

Out of interest, what were you using to install Burp? eg a package manager?


Alessandro Solano Dec 04, 2019 04:50PM UTC
I was just launching the self-contained linux install script from bash:

burpsuite_pro_linux_v2_1_06.sh

sha256 68b129ce5b7e40587919d3085ace003fcb64283e4ba3cb9753aa1db9b5930dc4

Hannah Law Dec 05, 2019 11:26AM UTC Support Center agent

Thank you, I’ve added that information to the bug report.


Post Your public answer

Your name
Your email address
Answer