Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Error Agent for new Scan

Caio Santos Dec 05, 2019 06:07PM UTC

BurpSuite edition: Enterprise
Installation type: Server & Agent(1) at one computer
Operating system: Ubuntu 16.04
Problem: any scheduled scan ends with 'Error Dispatching scan to 'Agent'
Agent is authorised and licensed.


Michelle Gillian Dec 06, 2019 11:52AM UTC Support Center agent

Hi

If you create a scan with the same settings (apart from the schedule), does that work ok?

To help us dig a bit deeper into this issue it would be useful to see the server and agent logs from when the issue occurred. By default these are in /var/log/BurpSuiteEnterpriseEdition/ on Linux. There is a separate log file for each day, and the current day’s log file doesn’t contain a date. The agent log files can be found on the agent machine.

If you’re happy to send them over could you email them to support@portswigger.net, please?


Caio Santos Dec 12, 2019 01:14PM UTC
Hello Michelle,

Thank you for your quick response. I saw this log: /var/log/BurpSuiteEnterpriseEdition/enterpriseAgent.<date>.log

And:

### The error may exist in net/portswigger/enterprise/common/repository/mybatis/mappers/AgentIssuesAndScansMapper.xml
### The error may involve defaultParameterMap
### The error occurred while setting parameters
### SQL: SELECT dbo.in_progress_scans_for_agent(?);
### Cause: com.microsoft.sqlserver.jdbc.SQLServerException: The EXECUTE permission was denied on the object 'in_progress_scans_for_agent', database 'burpenterprise', schema 'dbo'.
at org.apache.ibatis.exceptions.ExceptionFactory.wrapException(ExceptionFactory.java:30)
at org.apache.ibatis.session.defaults.DefaultSqlSession.selectList(DefaultSqlSession.java:150)
at org.apache.ibatis.session.defaults.DefaultSqlSession.selectList(DefaultSqlSession.java:141)
at org.apache.ibatis.session.defaults.DefaultSqlSession.selectOne(DefaultSqlSession.java:77)
"enterpriseAgent.<date>" [somente-leitura] 579L, 57220C

----------

Therefore, see the solution below:


sqlcmd:
> GRANT Insert ON yourschemaname.yourtablename TO yourusername;
>GO

https://stackoverflow.com/questions/55180236/the-insert-permission-was-denied-on-the-object-tablename-database-database-n

I changed the permission for user 'beagent' and it worked!!

Thanks,

Caio Santos






Michelle Gillian Dec 12, 2019 04:06PM UTC Support Center agent

Hi

Thanks for letting us know!


Post Your public answer

Your name
Your email address
Answer