Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

I have problem with the burp suite

Sherzad Dec 07, 2019 07:38AM UTC

What's wrong with this program? Can someone help me? How can I fix it?

Starting attack...
There was an error executing your Python script. This is probably due to a flaw in your script, rather than a bug in Turbo Intruder :)
If you think it is a Turbo Intruder issue, try out this script: https://raw.githubusercontent.com/PortSwigger/turbo-intruder/master/resources/examples/debug.py
For your convenience, here's the full stack trace:
java.lang.NullPointerException
at org.python.core.PyModule.module___init__(PyModule.java:64)
at org.python.core.PyModule.<init>(PyModule.java:47)
at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:112)
at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:94)
at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:71)
at burp.Fast_httpKt.evalJython(fast-http.kt:122)
at burp.TurboIntruderFrame$actionPerformed$1$1$1.invoke(fast-http.kt:277)
at burp.TurboIntruderFrame$actionPerformed$1$1$1.invoke(fast-http.kt:200)
at kotlin.concurrent.ThreadsKt$thread$thread$1.run(Thread.kt:30)

Another error when I starting Turbo Intruder

User Python error, check extender for full details: java.lang.NullPointerException


Hannah Law Dec 09, 2019 10:05AM UTC Support Center agent

Hi Sherzad

Have you tried running the debug script, as suggested by your extension?

It seems that some Python code written in the Turbo Intruder extension has triggered a NullPointerException, have you tried running some example scripts to check if they work (https://github.com/PortSwigger/turbo-intruder/blob/master/resources/examples/default.py)?


Anton Dec 17, 2019 10:42AM UTC
I have the same problem on my 32 bit system but on 64 bit system it runs well. Maybe that is the answer.

Ben Wright Dec 17, 2019 11:03AM UTC Support Center agent

Hi Anton,

The latest versions of Burp no longer support 32-bit architecture and Turbo Intruder has been recently updated so there may well be issues with running it on older versions of Burp.


Post Your public answer

Your name
Your email address
Answer