Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

HTTPS error on latest 2.1.07

Jordan Dec 20, 2019 03:48AM UTC

Hi, i am unable to load any webpages from

Error: Received fatal alert: handshake_failure

Ben Wright Dec 20, 2019 08:45AM UTC Support Center agent


Are you using the Community or Professional edition? Also, what version of Java are you using to run Burp?

Jonathan Dec 21, 2019 02:29PM UTC
Hello there,
I'm encountering same issue here. I updated my burp suite community desktop for mac and I'm having trouble intercepting requests from my browser. I'm using lastest firefox browser.

I always get "readHandshakeRecord" error on my dashboard

a Dec 23, 2019 02:49AM UTC
User Options > TLS > uncheck "Disable Java SNI extension"

Hannah Law Dec 31, 2019 02:05PM UTC Support Center agent

Jonathon, are you receiving any other errors or is it just that one?

If you try the step suggested by “a” does that change anything?

Post Your public answer

Your name
Your email address