Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Websockets not working with burp

Aliveli Jan 01, 2020 07:30PM UTC

my browser unable to connect *any* websocket while working with burp I also tried changing my browser.
I'm getting this error on firefox (similar messages in other browsers): "Firefox can’t establish a connection to the server at wss://"

reinstalled burp
tried diffrent browsers
switched to burp community
cleaned all files about burp

nothing worked

let me know if any further information required to help me to fix this issue

Hannah Law Jan 02, 2020 10:31AM UTC Support Center agent

Hi. For Firefox, would you be able to try unchecking the “Use this proxy server for all protocols” and then leave the SOCKS Host field empty within the Proxy settings?

Aliveli Jan 02, 2020 05:15PM UTC
Wow it's worked thank you :).

Ringo Jan 05, 2020 02:59AM UTC
Please update your directions to reflect this answer as I also struggled with this.

Ben Wright Jan 06, 2020 10:10AM UTC Support Center agent

Hi Ringo,

This behavior was only introduced in Firefox, Version 71 (prior to that version the suggested workaround was not required) so we are currently monitoring future Firefox releases to see if this issue persists. If it does then we will look to update our documentation accordingly.

Please let us know if you require any further information.

Ilke Jan 08, 2020 02:46PM UTC
It seems that this could be related to this bug:
They recently switched websockets to HTTP/2 and this won't work if you try to use a what so ever proxy.

Solution would be to downgrade to firefox 64, probz to the person that post the download link to this version.

Ben Wright Jan 08, 2020 03:08PM UTC Support Center agent


It is related to the following:

The suggested workaround provided by Hannah in this thread will work for Firefox, Version 71 so there is no need to downgrade.

Post Your public answer

Your name
Your email address