Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

interface catastrophically broken in recently updated Debian 7

Tom Joy Jan 29, 2015 12:31AM UTC

BURP Version: 1.6.09
Debian version: 7.8 (Wheezy)
JRE: both OpenJDK and Oracle JRE
XOrg Server: both XVFB and QXL
Invocation: java -jar ./burpsuite_pro_v1.6.09.jar

Mode of failure:

Burp Suite windows do not respond to any mouse input. Cannot interact with any buttons, tabs, lists, tables, text fields, scroll bars, etc. Other applications work fine.

Prior to Monday, Jan 26, Burp Suite 1.6.09 worked acceptably, although some input to popup dialogs, particularly when Burp detected a scratch directory in /tmp, was dropped unless the dialog was the only window visible on the desktop.

I attempted to open archived .jar distributions of burp.

v1.6.09 exhibited the failure
v1.6.08 exhibited the failure
v1.6.06 worked well
v1.5.09 worked well

I suspect the failure is related to an upgrade performed to the host machine, and manifested when the XOrg server was restarted to run a new version. I will pastebin the recent entries from /var/log/apt/history.log: http://pastebin.com/5ygKr8jF


Dafydd Stuttard Jan 29, 2015 09:53AM UTC Support Center agent

Sorry to hear about this problem. It does appear that a recent change to your system triggered the issue, since the current version of Burp was working ok before the system upgrade. Are other Java programs affected? Do you have any Burp extensions loaded?

I’m not aware of any significant changes that have been made in recent editions to the way Burp constructs its UI. If the problem is related to the display of dialogs, then it’s possible that the newer editions are displaying some dialog on startup that older editions aren’t.

Two things worth trying would be:

1. Manually clean any Burp folders in /tmp before starting Burp, in case a dialog about temp files is causing the problem.

2. Start Burp with the word usedefaults at the end of the java command, to prevent Burp from restoring any saved preferences.


Tom Joy Jan 29, 2015 08:23PM UTC
Dafydd, I tested your suggestion.

Invocation: java -jar ./burpsuite_pro_v1.6.09.jar usedefaults
Result: Burp works fantastic.

Invocation: java -jar ./burpsuite_pro_v1.6.09.jar
Result: Fails unresponsive.

I had noticed that Burp's configuration xml in ~/.java/.userPrefs/burp has leftover directives dating back from Burp 1.4. This file contains my license key and some other confidential information, or else I'd post it here publicly. Does Portswigger need access to this file to look for a parsing problem, or may I safely purge it?


Dafydd Stuttard Feb 02, 2015 08:57AM UTC Support Center agent

It does sound like some configured settings are causing the problem, which might include any loaded extensions.

You can easily clear the saved settings that are causing trouble in two ways:

1. With Burp running, restore defaults for all options, via the Burp menu, and gracefully shutdown.

2. Go to Help / Clean Burp from computer, and choose the option to remove saved preferences.

Both of these are preferable to directly modifying the Java preferences store on disk.

This question has received the maximum number of answers.