Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

URL does not get resolved

Craig Smith Mar 17, 2015 03:36PM UTC

Followed the getting started instructions and the intercept tab does display the requests but after I forward through them in Burp the browser does not resolve the URL and instead displays the following:

Burp Suite Professional
Error

Unknown host: http://www.overclockers.co.uk/


Dafydd Stuttard Mar 17, 2015 03:41PM UTC Support Center agent

This error message indicates that Burp is unable to resolve the domain name. If this is happening generally then Burp is probably unable to perform DNS lookups at all. If you normally use a network proxy to access the Internet, then you’ll need to configure the details for this at Options / Connections / Upstream proxy servers.


XOB Sep 08, 2015 11:33AM UTC
Hiya,

This exactly same error happened to me today as well. what kind of details need to configure at Options / Connections / Upstream proxy servers? destination host? authentication type and whose username & password?

would need this been fixed urgently. many thanks.

Dafydd Stuttard Sep 08, 2015 01:15PM UTC Support Center agent

This error really just means that Burp could not resolve the domain name into an IP address. This could be because:

- the domain isn’t registered
- Burp can’t resolve any DNS names
- Burp needs to use an upstream proxy that you need to configure as described previously
- Some temporary network issue
- Various other things …

If you normally use a proxy server (i.e. if you had one configured before you changed your browser settings to use Burp), then you’ll need to configure those same details in Burp. If you don’t normally use a proxy server, then one of the other possibilities might be happening.


vineet Oct 13, 2016 11:01AM UTC
In Burp, Go to "Project Option" tab>Upstream Proxy Server> Add proxy setting mentions in your network.
Better refer the settings mentions in IE, probably it should work.

Tarkan Sep 19, 2017 11:12AM UTC
In my case, it was just an error of the browser. Just delete all cookies referring to the dns. And also delete all caches, like history visits etc. Start again Burp!

Post Your public answer

Your name
Your email address
Answer