Support Center

Burp Community

See what our users are saying about Burp Suite:

How do I?

New Post View All

Feature Requests

New Post View All

Burp Extensions

New Post View All

Bug Reports

New Post View All
Documentation

Burp Suite Documentation

Take a look at our Documentation section for full details about every Burp Suite tool, function and configuration option.

Full Documentation Contents Burp Projects
Suite Functions Burp Tools
Options Using Burp Suite
Extensibility

Burp Extender

Burp Extender lets you extend the functionality of Burp Suite in numerous ways.

Extensions can be written in Java, Python or Ruby.

API documentation Writing your first Burp Suite extension
Sample extensions View community discussions about Extensibility
Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Text highlighted ... in black

Brian Jan 27, 2017 03:31PM UTC

Suddenly today, when I click in any Burp window that shows text, the text gets "highlighted" in black.
And it's black text. So I can't see anything.
If I open a different tool in Burp, and then come back, the view is restored, but only until I click in it. Then it goes black again.

Screenshot from fresh Burp Project where I only browsed to Portswigger: https://postimg.org/image/gloo6vkjz/

Any ideas on cause or solution?

I've tried restarting Burp.
I've tried a fresh project file.
I've tried "remove burp from this computer" (but when I clicked the Burp icon in my taskbar afterwards, Burp started back up again, so not sure how well that worked).

Windows 8.1
Burp Pro 1.7.16, installed with the Windows 64 bit installer method.

C:\>java -version
java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

I'm going to try it on a different machine next, but I'm kind of committed to the one where it's gone goofy on me...


Brian Jan 27, 2017 03:55PM UTC
Update:

Uninstalled via "Programs and Features", rebooted, reinstalled from fresh download of Win 64bit installer.
Opened new project file. Same problem.

...

"Remove Burp from Computer" will all options checked.
Manually deleted temp files after Burp closed.
Rebooted.
Uninstalled via "Programs and Features"
Rebooted.
Reinstalled.
Opened new project file ...
Same problem.

...

1.7.16 running as the jar file on my Linux box isn't showing this problem, and I can open my project files there, so I have a workaround for today.

Liam Tai-Hogan Jan 30, 2017 09:52AM UTC Support Center agent

Hi Brian

Thanks for your message.

Are you using the .jar or the .exe version of Burp Suite?

The .exe version comes bundled with it’s own version of Java.


Brian Jan 30, 2017 08:05PM UTC
I'm using the exe version - Burp Pro 1.7.16, installed with the Windows 64 bit installer method.

Liam Tai-Hogan Jan 31, 2017 10:10AM UTC Support Center agent

Thanks for the additional information Brian. We’ll try to reproduce this issue and get back to you.


Liam Tai-Hogan Jan 31, 2017 11:40AM UTC Support Center agent

Hi Brian

I’ve tried reproducing this on Windows 8.1 with Burp Pro 1.7.16 installed using the Windows 64 bit installer.

I’ve checked all display settings and I can’t reproduce the issue.

Have you tried altering the display settings at User Options > Display?


Brian Feb 06, 2017 04:00PM UTC
Installing the 1.7.17 Windows x64 update has resolved this issue.

Brian Jun 28, 2017 03:06PM UTC
...and it's happening again now.
Still Windows 8.1, still 64-bit installed version.
Now on version 1.7.23.

Screenshot: https://postimg.org/image/oz9kail3b/

Paul Johnston Jun 29, 2017 09:02AM UTC Support Center agent

Hi Brian,

Sorry to hear you’re still having trouble.

Can you send me your debug ID? It’s in User options > Misc > Performance Feedback


Paul Johnston Jun 29, 2017 12:29PM UTC Support Center agent

Hi Brian,

I’ve looked at this some more and I cannot reproduce it – on what I think is an identical system.

Does this occur all the time? If you open a fresh burp, type some text in Repeater – does highlighting come up black initially? If it’s intermittent, any information you can provide on how to trigger the behavior would be very helpful.

Also, I think you’re using the Metal theme. Does this occur with the default Nimbus theme?


Brian Jun 29, 2017 04:12PM UTC
It's intermittent - was working fine last time on the same VM and same Burp installation. But once it starts, I can't make it stop, even by uninstall/reinstall or using the jar version or older versions.

Yes, it happens with the Nimbus theme as well.

I'm doing this in a VirtualBox VM. (Virtualbox 5.1.22 on Ubuntu 16.04. VM is Windows 8.1 Pro)

I got it working late yesterday by disabling all hardware acceleration for video in the VM config. At least, that's the last thing I did before it started working... I'll change it back after I'm done with this test and see if I can get you a clearer root cause.

Paul Johnston Jun 30, 2017 07:39AM UTC Support Center agent

Hi Brian,

Disabling hardware acceleration was a good idea, lets hope that resolves it.

When the issue occurs, does rebooting the system help? Try both the VM and the host.

I have a feeling this is a bad interaction between Virtual Box and your graphics card. We’ve not had other reports of this issue so it must be something unusual.

Are you using the VM directly within Virtual Box? An alternative is to remote desktop from your host to the VM. I actually do that routinely as I slightly prefer the experience. In your case it may side-step the issue.


Brian Jun 30, 2017 02:55PM UTC
Good idea about RDP. I will try that if it happens again.
I do seem to be the only one with this issue, so ...

floyd Feb 15, 2018 12:47PM UTC
I experienced the same issues in Windows 10 on Virtualbox where I installed Burp via exe installer. It seems to be a Virtualbox 3D hardware acceleration issue.

The workaround is simply disabling 3D hardware acceleration in the Virtualbox settings under Display uncheck the checkbox "Enable 3D hardware acceleration". I rebooted the VM in between and only changed this setting in between reboots.

There are topics discussed at Virtualbox:
https://www.virtualbox.org/ticket/14985

The download page https://www.virtualbox.org/wiki/Downloads currently states:
"Important: The Guest Additions which come with VirtualBox 5.2.6 and 5.1.32 do not work properly on Linux guests with 3D enabled. Here are updated versions for 5.2.6 and 5.1.32.". Although I have a Windows guest, that might still indicate that work is being done in the 3D hardware acceleration feature...

floyd Feb 15, 2018 02:03PM UTC
Together with Paul also just confirmed that running with:

.\jre\bin\java.exe "-Dsun.java2d.d3d=false" -jar .\burpsuite_community.jar

The issue is gone and that's another workaround. When running with:

.\jre\bin\java.exe "-Dsun.java2d.d3d=true" -jar .\burpsuite_community.jar

The issue is still there (also running without sun.java2d.d3d parameter as it's enabled by default).

Post Your public answer

Your name
Your email address
Answer