Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

NET::ERR_CERT_VALIDITY_TOO_LONG

Mahendra Mustika Wijaya Feb 23, 2018 07:55AM UTC

Information
------------------------------------------------------------
Version : Burp 1.7.32 (Professional)
Burp Proxy Server : Kali Linux
Certificate : Android Device 7.0 (Nougat)

Issue
----------------------------------------
NET::ERR_CERT_VALIDITY_TOO_LONG

Tested using chrome, if using firefox it cannot open the URL in secure protocol.

when using normal protocol / HTTP it's normal.

we try with apps android to capture the traffic but no traffic were captured.

i think the certificate validity too long, we already regenerate this certificate many times but the result still same.

waiting for your reply,

Regards,
Mahendra M.W.


Liam Tai-Hogan Feb 23, 2018 12:11PM UTC Support Center agent

We’re going to look at providing a configurable validity period.

In the meantime, you can generate your own CA certificate with a suitable validity period using openssl, and import it into Burp. The dynamically generated certificates are always given the same validity period as the CA.


Mikail Apr 16, 2018 12:37AM UTC
Liam, do you have any updates you could share with the community please? i.e., when do you expect the option to be able to configure CA options within Burp to be released?

Liam Tai-Hogan Apr 16, 2018 09:34AM UTC Support Center agent

We have this logged in our development backlog and we’ll inform you when the work is complete. Unfortunately, we can’t provide an ETA.


Post Your public answer

Your name
Your email address
Answer