Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

gettin error code : SSL_ERROR_RX_RECORD_TOO_LONG

Rizwan Nov 09, 2018 12:30PM UTC

iam using firefox ,i changed proxy and imported CA certificate. when i try to intercept iam getting error message

Secure Connection Failed

An error occurred during a connection to www.google.com. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.


Liam Tai-Hogan Nov 09, 2018 01:15PM UTC Support Center agent

Thanks for your message Rizwan. Which version of Burp are you using? Have you updated to the latest version?


chucho santos Nov 10, 2018 12:14AM UTC
Hey that happening to me. I'm ussing version v1.7.36

Jio Nov 10, 2018 03:25AM UTC
Same issue. I'm using Community Ed. v1.7.36

gdev Nov 10, 2018 01:47PM UTC
Same here I'm using Community Ed. v1.7.36

gdev Nov 10, 2018 02:14PM UTC
downgrading the java version solved this for me (was using 11)

chucho santos Nov 10, 2018 07:19PM UTC
I'm using java 10 and still don't working

chucho santos Nov 10, 2018 07:27PM UTC
EDIT:
You were right, use this in linux and choose the right version

sudo update-alternatives --config java

sudo update-alternatives --config javac

sudo update-alternatives --config javaws

Use 10 version of java

Liam Tai-Hogan Nov 12, 2018 03:14PM UTC Support Center agent

Thanks for the update Chucho.


Noman Riffat Nov 18, 2018 05:21AM UTC
After downgrading java as explained above by Liam Tai-Hogan, restart burp to make it work

Noman Riffat Nov 18, 2018 05:22AM UTC
Sorry by chucho santos I mean :)

alt3kx Nov 22, 2018 10:53AM UTC
FYI latest Java upgrade on my Linux box same error appears, my fix just downgrade the JAVA version or run the following command and start BurpSuite Professional v2.0.12beta

# update-alternatives --config java
There are 4 choices for the alternative java (providing /usr/bin/java).

Selection Path Priority Status
------------------------------------------------------------
0 /usr/lib/jvm/java-11-openjdk-amd64/bin/java 1111 auto mode
1 /usr/lib/jvm/java-10-openjdk-amd64/bin/java 1101 manual mode
2 /usr/lib/jvm/java-11-openjdk-amd64/bin/java 1111 manual mode
3 /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java 1081 manual mode
4 /usr/lib/jvm/java-9-openjdk-amd64/bin/java 1091 manual mode
Press <enter> to keep the current choice[*], or type selection number:

#/usr/lib/jvm/java-10-openjdk-amd64/bin/java -Xms16 -Xms4G -XX:MaxPermSize=1024M -jar burpsuite_pro_v2.0.12beta.jar &

Regards
/alt3kx



Liam Tai-Hogan Nov 22, 2018 02:47PM UTC Support Center agent

Thanks for the update alt3kx.


vladirov Dec 16, 2018 11:34PM UTC
Downgrading java to 10 works ...."kali OS"

RB Dec 21, 2018 09:37PM UTC
in the current kali repos there is not java 10 version of jre. is there a way to fix this issue without adding jav10? I would really like to avoid any additional repositories atm.

Liam Tai-Hogan Dec 24, 2018 12:08PM UTC Support Center agent

Have you tried using the platform installer version of Burp Suite?


Bayani Elogada Dec 29, 2018 07:27PM UTC
@RB, as of December 30, 2018, the one from the Kali Linux repo seems to have it. You simply have to reconfig it using

~# update-alternatives --config java
~# update-alternatives --config javac
~# update-alternatives --config javaws

and select the right version. as mentioned by @chucho above. It seems to have worked for me so far. However, outside of that, I also add test.currentTimeOffsetSeconds to 11491200 (as an integer) in about:config, so if that one fails, the Firefox configuration might help too.

Liam Tai-Hogan Dec 31, 2018 09:59AM UTC Support Center agent

Thanks for the additional information Bayani.


Bayani Elogada Dec 31, 2018 08:41PM UTC
Perhaps referencing this thread might also be useful for that other thread about Burp refusing HSTS. I got this problem mainly because I had HSTS problems that I tried fixing. After tweaking Firefox, I reached OP's error trace, but reverting to JRE 10 fixed both the HSTS problem and OP's problem for me.

douglas Jan 31, 2019 07:17PM UTC
hi
i had exactly the same problem as mentioned above . i downgraded to java 10 and it now works . thank you . Running latest version of burp as well

Liam Tai-Hogan Feb 01, 2019 09:12AM UTC Support Center agent

Thanks for the update Douglas.


Ashutosh Verma Feb 13, 2019 06:17PM UTC
Downgrading java to version 10 worked for me too

Eric Feb 21, 2019 05:20AM UTC
Hey all,

Thanks for the help for this issue. I actually had to revert back to Kali 2018.4 to get it to work properly, since K 2019.1 only offers Java 8 and 11. I'm sure it'll be fixed soon enough!

John Feb 24, 2019 02:32PM UTC
Just to add if you are on the latest Kali which doesn't offer V10, downgrading to V8 also works

Elliot Feb 24, 2019 06:50PM UTC
how do you downgrade to v8 on kali?

apurv Feb 25, 2019 07:27PM UTC
This problem occur in kali 2019.1 and this kali use java 11.

Solve: run this command in terminal

"sudo update-alternatives --config java"

Then you choose selection 2 : /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java

That means you choose java 8

Mirnes Alic Mar 18, 2019 08:08AM UTC
apurv recipe worked just fine. I selected java 10 jdk, it was fine. Running kali 2019.1

Chandima Athapattu Mar 24, 2019 05:54PM UTC
Downgrading from java 11 to java 8 in Kali 2019.1 worked for me...

But any side effects because of this?

Thanks...

CGonzalo Apr 01, 2019 06:32PM UTC
Thank you, this work for me in Manjaro (based in ArchLinux):

Steps:

archlinux-java status
sudo archlinux-java set [JAVA-X-JDK]

https://medium.com/@petehouston/switch-java-versions-on-any-systems-you-like-f0c996b4f57a

Rick Dobbs Apr 04, 2019 03:01PM UTC
Has this been looked at by portswigger? I really would not prefer to downgrade my java to get burp to work.

Liam Tai-Hogan Apr 05, 2019 11:25AM UTC Support Center agent

Rick, could you let us know which OS you are using?


Rick Dobbs Apr 08, 2019 01:20PM UTC
Same as most people above, Kali 2019.1


Paul Johnston Apr 09, 2019 09:45AM UTC Support Center agent

Rick – thanks for clarifying. If you are a Burp Community Edition user, you can either downgrade your Java, or use the Burp Linux Installer:

- https://portswigger.net/burp/communitydownload

The latest versions of Burp Professional have fixes so that Burp correctly works with the latest Java versions. At the moment there isn’t a Community Edition release with these features.


Richard Apr 15, 2019 11:09PM UTC
The following worked for me on Kali.

sudo update-alternatives --config java

sudo update-alternatives --config javac

Use 10 version of java

I attempted, sudo update-alternatives --config javaws, but got a message saying there was no alternative for javaws

Restarted burp and I can now connect to google, facebook, etc.

THANKS chucho

Liam Tai-Hogan Apr 16, 2019 08:59AM UTC Support Center agent

Thanks for the update Richard.


saikoDai Apr 16, 2019 07:41PM UTC
Thank for the update Richard.
Choosing version 10 of Java worked for me on v1.7.36 Burp CE.

gnopor May 11, 2019 09:11AM UTC
I selected java 10 jdk, it was fine. Running kali 2019.1

Rose Krawczuk May 13, 2019 11:01AM UTC Support Center agent

Thanks for the update.


Pencer May 22, 2019 09:08PM UTC
Just letting you know i'm on latest version of Kali, fully updated. Which means i'm on Burp CW 1.7.36. I've installed the ssl cert in to Firefox as described but still get the ssl error.

Doing a sudo update-alternatives --config java, shows me this:

Selection Path Priority Status
------------------------------------------------------------
0 /usr/lib/jvm/java-11-openjdk-amd64/bin/java 1111 auto mode
1 /usr/lib/jvm/java-11-openjdk-amd64/bin/java 1111 manual mode
* 2 /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java 1081 manual mode

No version 10 for Java any more, however setting to version 8 has worked. So I'll stick with that for now.

Hope that helps!



Ramikan Jun 12, 2019 02:04PM UTC
If you don't prefer to downgrade java or burp then try this on your Firefox browser.

Type: about:config on the URL
Search for "security.tls.version.max" and set the value to '3' instead of '4'.


Reference: http://kb.mozillazine.org/Security.tls.version.*

Thanks

deepanshu singh Jun 30, 2019 05:50AM UTC
thanks @Ramikan your method

"
If you don't prefer to downgrade java or burp then try this on your Firefox browser.

Type: about:config on the URL
Search for "security.tls.version.max" and set the value to '3' instead of '4'.


Reference: http://kb.mozillazine.org/Security.tls.version.*
"
works.

koba Aug 18, 2019 03:09PM UTC
I also went through same problem.

# Failed
Kali:2019.1
Burp:1.7.36
java 11
javac 11

# Success
Kali:2019.1
Burp:1.7.36
java 8
javac 11

This thread were very helpful for me. Thank you!

Post Your public answer

Your name
Your email address
Answer