Support Center

Burp Community

See what our users are saying about Burp Suite:

How do I?

New Post View All

Feature Requests

New Post View All

Burp Extensions

New Post View All

Bug Reports

New Post View All
Documentation

Burp Suite Documentation

Take a look at our Documentation section for full details about every Burp Suite tool, function and configuration option.

Full Documentation Contents Burp Projects
Suite Functions Burp Tools
Options Using Burp Suite
Extensibility

Burp Extender

Burp Extender lets you extend the functionality of Burp Suite in numerous ways.

Extensions can be written in Java, Python or Ruby.

API documentation Writing your first Burp Suite extension
Sample extensions View community discussions about Extensibility
Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Errors: unable to relocate function

Steve Pinkham Dec 12, 2018 05:42PM UTC

I am using Burp Pro 2.0.13 on a Kali VM up to date as a week ago at least. It's been working fine with a normal manual crawl and send to scanner style workflow. Recently I just tried to run a new scan on a site using the new scan button and all the default settings, and the scan can't finish as it keeps throwing "Errors: unable to relocate function" for 15+ items in a row and stopping.

This behavior continues even after a restart with ram, disk and temp all at less then 10% used, with all extensions disabled and the embedded browser health check showing "success" for all items. I can add things to other audit tasks and they run fine.

I've never seen anything like this, so have no idea where to start.


Liam Tai-Hogan Dec 13, 2018 09:48AM UTC Support Center agent

Thanks for your message Steve. Do you have performance feedback enabled (User options > Misc > Performance feedback)? If so, could you provide us with your diagnostics (Help > Diagnostics)?


Anthony Obriot Jan 24, 2019 08:37PM UTC
Any cause for this found? Am getting the same error.

Liam Tai-Hogan Jan 25, 2019 07:44AM UTC Support Center agent

Anthony, we haven’t been able to replicate the issue. If you have performance feedback enabled, would it be possible to send us your diagnostics?


Post Your public answer

Your name
Your email address
Answer