Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Possible bug: Missing hosts in site map in branch 2.x

Nicolas Devillers Jan 10, 2019 02:49PM UTC

I think I spotted a bug on burp 2.x which wasn't there on the previous branch.
It might be reproductible with the following steps (hopefully):

- Setup a scope
- Burp ask if you want to "limit item sent to proxy history to the scope" : answer yes
- Change the scope to add a new host
- Reenable proxy history for everything
- Browse the new host added in to the scope:

Result: New host requests appears in proxy history but doesn't appears in sitemap.

Note: Not sure it matter but I use the "advanced scope control" feature when the bug occur. I'm also not 100% sure the bug is linked to the "don't send item to proxy if not in scope" feature.

I currently use last burp suite: 2.0.13beta


Nicolas Devillers Jan 10, 2019 02:58PM UTC
Note: The bug will persist even if I totally disable the scope and if I use the intruder to manualy add item to the sitemap.

As if burp suite kept an arraylist of "out of scope forever" hosts.

Liam Tai-Hogan Jan 11, 2019 11:05AM UTC Support Center agent

Nicolas, we’ve tested this following your steps and we can’t reproduce the issue.

Have you closed and opened Burp when the issue occurred? It may be that task execution engine was paused. You will see a warning in the Dashboard tab if so.


Nicolas Devillers Jan 15, 2019 01:28PM UTC
Hi Liam,

My burp was still open and task execution engine was indeed paused! I didn't know about this.

Sorry for opening a non-issue.

Thanks again!
Nicolas

Liam Tai-Hogan Jan 15, 2019 01:56PM UTC Support Center agent

No problem Nicolas, thanks for letting us know.


Post Your public answer

Your name
Your email address
Answer