Support Center

Burp Community

See what our users are saying about Burp Suite:

How do I?

New Post View All

Feature Requests

New Post View All

Burp Extensions

New Post View All

Bug Reports

New Post View All
Documentation

Burp Suite Documentation

Take a look at our Documentation section for full details about every Burp Suite tool, function and configuration option.

Full Documentation Contents Burp Projects
Suite Functions Burp Tools
Options Using Burp Suite
Extensibility

Burp Extender

Burp Extender lets you extend the functionality of Burp Suite in numerous ways.

Extensions can be written in Java, Python or Ruby.

API documentation Writing your first Burp Suite extension
Sample extensions View community discussions about Extensibility
Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

failed to start Burp Suit Professional

Josie Feb 06, 2019 10:54PM UTC

Hi there,

We are currently evaluating Burp. I registered myself using my company account and downloaded "burpsuite_enterprise_windows-x64_v1_0_12beta" and associated license key from that account. I installed the software successfully on my windows 10 machine with the following configuration:
- web server set to 9999
- use embedded database
- install a instance of agent on the same machine
- Java runtime in place

After the installation, I tried to run Burp suite from "C:\Program Files\burpsuite_enterprise\burp\burpsuite_pro_v2.0.14beta.jar" and it fails on the license validation with this error "The supplied license key is not valid for this version of Burp. Please enter a valid license key."

Could you please what went wrong and how to fix it? One thing I noticed is that I downloaded enterprise version but the "Burp suite" is on professional.

Many thanks

Josie


Liam Tai-Hogan Feb 07, 2019 11:09AM UTC Support Center agent

It looks like you’re entering an Enterprise license in to an instance of Burp Professional.

The Burp jar file is part of the Enterprise file, but that isn’t how you launch the Enterprise Edition.

You launch Burp Enterprise via a browser:

- https://portswigger.net/burp/documentation/enterprise/getting-started/installation#post-installation-configuration

Carry out the following steps to complete the installation:

Browse to the web server on the relevant host and port (the default port is 8080).

Log in using the credentials for the administrator account that were specified during installation.

Have you tried using your browser using the relevant host and port? You should have configured this during the installation process (wizard).


Post Your public answer

Your name
Your email address
Answer