Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Unable to load library (PKCS#11 file) after updating Burp?

Omer Feb 11, 2019 07:18PM UTC

Hi all,

I recently updated Burp to the latest version, as I was getting a notification to update each time I started up the tool. However, I am now having a problem with trying to manually select a library for the Client SSL Certificate. Each time I select the acpkcs211.dll file, after selecting the "Manually select library" option, I get an error saying: "Unable to load library - check file is correct and device is installed".

I was able to load it fine prior to the update, but have been not able to do so since updating the tool.

Thoughts on what could be going wrong here?

Thanks!


Paul Johnston Feb 12, 2019 09:57AM UTC Support Center agent

This is related to the upgrade of the embedded Java which occurred in Burp 2.0.14. We hope to have a fix for this in a future Burp beta.

In the meantime, you can either go back to Burp 2.0.13 or you can use a JVM you’ve downloaded yourself rather than the embedded one.


Omer Feb 12, 2019 02:54PM UTC
Thank you for your response.

How do I go about reverting back to the old version (Burp 2.0.13)? Is there an option to do it from within the tool itself, or will I have to uninstall the newer version and then re-install the older version of Burp?

Paul Johnston Feb 12, 2019 02:57PM UTC Support Center agent

You need to download the old version from our website and install that. You don’t actually need to uninstall the newer version, the installer will overwrite it.


Omer Feb 12, 2019 03:34PM UTC
Thank you, sir!

Post Your public answer

Your name
Your email address
Answer