Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

localhost - worker process - not in burp - MAC OS

Eric Jul 04, 2019 04:50PM UTC

I currently use Chrome with SwitchySharp extension for Proxy or firefox with proxysetting into firefox.
Everytime I try to catch traffic comming from localhost, it does not work. I must add an host to my etc/host to test with another adress for example http://webgoat . (relyied to 127.0.0.1).
I found that tricks so I was happy. BUT !

Now, I must test a webSite who use WorkerProcess to make backendCall, those call isn't into burp HTTP History even if I see those into network tab into chrome / firefox debugging tool.

For example :
This request is in BURP :
Request URL: https://*****/price
Request Method: OPTIONS
Status Code: 204 No Content
Remote Address: 127.0.0.1:8083
Referrer Policy: no-referrer-when-downgrade

THis request IS NOT into BURP
Request URL: https://*****/price
Request Method: POST
Status Code: 200 OK (from ServiceWorker)
Referrer Policy: no-referrer-when-downgrade

Could you help me please ? I'm On this trouble for 2 days now. :-(


Liam Tai-Hogan Jul 08, 2019 10:56AM UTC Support Center agent

Is this a non-proxy aware client?

Burp’s support for invisible proxying allows non-proxy-aware clients to connect directly to a Proxy listener. This option is sometimes useful if the application you are targeting employs a thick client component that runs outside of the browser, or a browser plugin that makes its own HTTP requests outside of the browser’s framework.

- https://portswigger.net/burp/documentation/desktop/tools/proxy/options/invisible


Eric Jul 09, 2019 06:25PM UTC
I see all the call from the browser (chrome) it's look alike everything happen into browser...

I dont know why but even if I try this call sequence 200 times, I always only see OPTION request in BURP and I never see the POST request.

This is not the only site that I get the problem... Often when a WorkerProcess make the call, I see nothing into my http history.


Éric Jul 09, 2019 07:57PM UTC
And If you have an hint for my localhost... On macOS, I never see trafic from localhost when testing on my Mac.

Liam Tai-Hogan Jul 10, 2019 11:03AM UTC Support Center agent

The hosts file solution is the only solution we are aware of for this issue. Did you say this was working initially?

Did you try using the invisible proxy feature?


Post Your public answer

Your name
Your email address
Answer