Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

NET::ERR_CERT_WEAK_KEY

Martin Orem Nov 05, 2019 02:58PM UTC

Hello,

I've just updated my macOS to Catalina and Burp to version Version 2.1.05. The problem is that Chrome does not want to initiate a connection with Burp Proxy and shows the error "Your connection is insecure" with the following description: NET::ERR_CERT_WEAK_KEY.

I presume the Burps CA generates private keys of 1024 bits, however these are no longer supported in this environment. The minimal requirement seem to be 2048 bits. Could you look into it? I did not find a proper way to enlarge the key.

Thank you in advance.
Beste regards,
Martin


Martin Orem Nov 05, 2019 09:08PM UTC
I've just imported custom CA to Burp and my system, which was able to generate sufficient key and certificate.

Post Your public answer

Your name
Your email address
Answer