Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Client Failed to negotiate a TLS Connection to respective application

Satya Prashanth Challa Jan 06, 2020 01:30PM UTC

Hello BurpSuite Support,

When I was trying to test a web application using Burp Suite 2.1.07 it is showing with an error Client failed to negotiate a TLS Connection to www.xxxxxxx.com: Received fatal alert:_certificate unknown.

Steps followed on my side: Installed Burp CA Cert in Chrome browser, IE, Firefox—still shows up with same error.

2. Tried to change settings in Project Options> TLS—Still DIDN’T WORK.

We had an implementation this week. Can you please help us in troubleshooting this issue.

Thanks,
Satya.


Hannah Law Jan 06, 2020 02:10PM UTC Support Center agent

Hi Satya

Have you tried deleting and reinstalling the Burp certificate?

Could you also tell me your OS, your Java version, whether you are using Professional or Community, and if you are using the platform installer or the plain .JAR file?


Satya Prashanth Challa Jan 06, 2020 03:52PM UTC
Hi Jan,

Yeah i have installed cert twice. I am using Windows 10 Machine to run the scans.I am using Professional version.

Thanks,
Satya.

Satya Prashanth Challa Jan 06, 2020 04:03PM UTC
Hi Jan,

I have Java 8 Update 231 on my machine.

Thanks,
Satya.

Hannah Law Jan 07, 2020 09:44AM UTC Support Center agent

Hi Satya

Are you using the platform installer version or the plain .JAR file?

Could you try running Burp using a different Java version?


Satya Prashanth Challa Jan 07, 2020 12:43PM UTC
Hi,

It is a platform installer. In Past i used previous version of 2.1.07. It worked fine without any issue.

Thanks,
Satya.

Ben Wright Jan 07, 2020 01:30PM UTC Support Center agent

Hi Satya,

Just to confirm, is this behavior common across all sites or just the particular one that you are currently testing? If it is just one site, is the site public facing and are you able to send us details so that we can investigate from our side (if you want to send us an email with the details then please feel free)?

You also say that you have used previous versions of Burp and it worked fine – do you mean that Burp has worked previously against the site you are having issues with now or that it worked fine in general?


Satya Prashanth Challa Jan 07, 2020 03:05PM UTC
I have used Burp for the same Application and it went find in the month of november. It is a internal website. Can we schedule a call to resolve this issue.

Thanks,
Satya.

Liam Tai-Hogan Jan 07, 2020 04:06PM UTC Support Center agent

Support is provided via email only.

When you have used previous versions of Burp and it worked fine – do you mean that Burp has worked previously against the site you are having issues with now or that it worked fine in general?

Would it be possible to send a screenshot of the error message to support@portswigger.net?


Satya Prashanth Challa Jan 07, 2020 04:45PM UTC
With previous versions of Burp for the site am working on ran the scan without any issues. For the latest version of version of Burp, facing this issue. I just want to make sure whether latest version is causing this issue. I will take the screenshot and update to you.

Thanks,
Satya.

Satya Prashanth Challa Jan 07, 2020 09:23PM UTC
Emailed the screenshot showing error message to support@portswigger.net

Ben Wright Jan 08, 2020 08:17AM UTC Support Center agent

Thank you Satya.

We will get back to you via your email.


Post Your public answer

Your name
Your email address
Answer