Bug Reports

Report a bug

  • High CPU Utilization

    I am seeing an extremely high usage on my CPU in burpsuite. I am also seeing the RAM consumption go up to 16-17GB in a session. I am in the middle of a test of an API for a client. I can kill burp and then reload it. Then it is okay for about 15-20 minutes before returning to high usage. Let me know what you need to determine what might be causing this issue.

    1 Community Answer
    May 23, 2019 04:17PM UTC
  • Problems updating Burp Enterprise

    It seems that the online update has some sort of built-in timeout and we are consistently hitting it and unable to update. With previous versions, the update would finish after many retries, but since v1.0.14beta we have not been able to update. I've talked to our infrastructure guys and it seems that there is no throttling or blocking of Burp update downloads. The following error is ou...

    3 Agent Answers    2 Community Answers
    May 21, 2019 06:22AM UTC
  • Repeater abnormal Server response "400 Bad request"

    http://oa.wz.zj.cn/ctkj_acl/html/login.html the normal request data: POST /dwr/call/plaincall/FrontAction.getmobilePwdPortal.dwr HTTP/1.1 Host: oa.wz.zj.cn User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 Accept: */* Accept-Language: zh-CN,zh;q=0.8,en-US;q=0.5,en;q=0.3 Accept-Encoding: gzip, deflate Content-Type: text/plain Referer: http://oa.wz...

    0 Community Answer
    May 21, 2019 06:20AM UTC
  • Burp Suite 2.0 doesn't play well with Google Drive File Stream

    I've had issues with Burp and GDrive File Stream on Windows 10 (fresh install). Specifically, automatic backups fail and the explicit saving of a project in the GDrive location (G:/ by default) results in the following error message: "Failed to create new project file: java.nio.channels.OverlappingFileLockException" The problem persists even after marking the destination dire...

    1 Agent Answer    0 Community Answer
    May 16, 2019 10:22PM UTC
  • scan don't work, burpsuite 2.0 beta

    I launch the burp from the .jar file or install the .sh and the "scan", "audit and crawler" dont work, it only appears in the dashboard, but neither a stop or pause message, just does not work

    1 Agent Answer    0 Community Answer
    May 16, 2019 12:05AM UTC
  • Burp Enterprise - Cannot View Scan Results after Auto-update

    I can run scans all day long and my license is active, but I cannot view scan results of new or previous scans. This must have started happening after one of the recent software auto-updates. Please help and please develop complete unit tests and QA before releasing new versions of the software. Error message in UI: An unexpected problem occurred. If this problem persists, please contact suppo...

    2 Agent Answers    1 Community Answer
    May 15, 2019 03:38PM UTC
  • An unexpected error occurred after update of Burp Enterprise

    After the auto updated installed the most recent version the following error pops up when I click on a scan to see the details: An unexpected error occurred. If this problem persists, please contact support@portswigger.net.

    1 Agent Answer    1 Community Answer
    May 10, 2019 08:56AM UTC
  • Content Type incorrectly stated

    The response states that the content type is application/font-woff2. However, it actually appears to contain unrecognized content. If the URL path can be manipulated to end with ".html", the following browsers may interpret the response as HTML: Internet Explorer 11 Internet Explorer 11 (Compatibility Mode) We have check the web.config setting and they are set to the recommended st...

    1 Agent Answer    0 Community Answer
    May 09, 2019 09:18PM UTC
  • Web Security Academy OS Command Injection, Simple Case

    I've been trying to do this one (Web Security Academy OS Command Injection, Simple Case) but nothing seems to work. I even used the proposed solution and it didn't work at all so my suspicion is that the challenge is broken.

    1 Agent Answer    0 Community Answer
    May 08, 2019 07:06AM UTC
  • https

    i have installed the certificate into my browser (firefox) and when i browse an https website i sometimes get a request to forward when intercept is on but even when i press forward, it still doesn't appear in my site map.

    1 Agent Answer    0 Community Answer
    May 05, 2019 08:41PM UTC