Bug Reports

Report a bug

  • Bug in IRequestInfo.getUrl()

    Hello, There is a bug in IRequestInfo.getUrl() that is related to how the hostname is retrieved. Currently getUrl() uses the hostname specified in the target options instead of the Host header in the HTTP request. However, what if the user specified a different hostname with the same target? Plugins would not be able to correctly report the affected URL using the IRequestInfo.getUrl() method if...

    2 Agent Answers    1 Community Answer
    May 14, 2015 01:36AM UTC
  • Request never complete

    Using burp free with OSX 10.10 (also tried in a kali VM using OSX as the host os) I've set up burp now in several different browsers, trusting the SSL certs and all even using the plug-n-hack plugin on firefox to auto setup the configuration, but every time I visit a site it never loads, the requests are logged successfully in burp but we never actually receive the response, not in burp or...

    1 Agent Answer    0 Community Answer
    May 03, 2015 08:52AM UTC
  • Unable to type anything on any field

    Any field that requires me to type anything, does not accept any input. I am using OS X 10.10.2, with Java version 1.8.0_40, and Burp Suite is at v1.6.17. For example, when I go to options-Connections and check to do platform authentication when I choose add the new display opens up but I am not able to type anything. Regards, Michael

    1 Agent Answer    0 Community Answer
    Apr 29, 2015 04:11AM UTC
  • How do i get this fixed ?!

    I've downloaded webGoat which now runs on port 8080, and Burp is installed on port 8181 , i set up the browser connection proxy to burp proxy listener on and the target scope to localhost:8080 and set the upstream proxy servers to mu corporate proxy address i can open all webcites but not http://localhost:8080/WebGoat/welcome.mvc wich im aiming to interce...

    1 Agent Answer    1 Community Answer
    Apr 27, 2015 08:22AM UTC
  • java.net.socketexception:connection reset

    Hi, i'm using the licensed version of burp suite Pro. when the scanner is triggered, the following error message is listed in 'Alert' tab. java.net.socketException:Connection reset. The occurrence of this issue is in huge numbers, it increased based on the number of request sent from Burp scanner. Does it affect the scanning? Please guide. Regards, Ranjith

    1 Agent Answer    1 Community Answer
    Apr 27, 2015 08:16AM UTC
  • Proxy Listeners aren't visible

    Hi, When I add a proxy listener on Proxy / Options / Proxy Listeners, I can't see the added listener on Burp GUI. So I can't edit or remove it with mouse cursor (cursor keys can help the scene). Burp Suite Professional v1.6.17 Windows 7 pro 64bit java version "1.7.0_75" thanks.

    2 Agent Answers    0 Community Answer
    Apr 27, 2015 04:59AM UTC
  • intruder tab problem

    Dear's i was using the app normally then restart the machine after that i tried to open the intruder tab the sub tabs is dim and cant add any data. i need your help as soon as possible please. Screenshot : http://i59.tinypic.com/2q30yfk.jpg BR,

    4 Agent Answers    6 Community Answers
    Apr 24, 2015 08:11AM UTC
  • File Ownership Not Returned

    Hello, I am playing with the MDSEC training lab for the Java Applet input validation bypass. As part of this I was using the right click 'Paste from File' option to inject my modified client. While this worked it looks like the Java thread for burp has maintained ownership of the .class file. So I cannot delete the .class to try a second modification to the applet. On windows the ...

    2 Agent Answers    0 Community Answer
    Apr 19, 2015 08:06PM UTC
  • Collaborator polling ssl root cert

    Stood up a private collab server and everything seems to be running as expected. Looking at the polling server on 9443 however I get a cert error warning. Same cert is used for 443 and there's no warning. Not sure if I have a configuration issue with my collaborator.config or if something else is going on. The cert itself is a comodo wildcard cert for my domain.

    2 Agent Answers    1 Community Answer
    Apr 19, 2015 04:44AM UTC
  • GetParameters (IRequestInfo) bug

    Hi, I am using the "getParameters()" method of IRequestInfo and I have found a bug. When a request is parsed by this method it returns all the parameters that it found in "get parameters", "post parameters" and cookies. If the following request is parsed by this method: GET /url.php?param1=value1 Host: x.x.x.x Cookie: cookie1=value2 GetParameters() returns:...

    2 Agent Answers    1 Community Answer
    Apr 16, 2015 11:20PM UTC